NEW PERSPECTIVES

PowerPoint Tutorial 2:

Adding and Modifying Text
and Graphic Objects




Objectives

* |Insert a graphic from a file

* |nsert, resize, and reposition clip art

* Modify the color and shape of a bitmapped
graphic

* Apply effects and styles to a graphic

* Draw and format shapes

* Add text to a shape

* |nsert and format text boxes

* Flip and rotate objects
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Objectives

* Modify the Slide Master

* Create SmartArt diagrams

* Modify a SmartArt diagram

* Apply animations to graphics

* Customize animations

* Insert headers on handouts and notes pages
* Broadcast a presentation
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Modifying Graphics

Click the Color button
to display a gallery of
choices to make a
bitmapped graphic
monochromatic. For
photos, you can also
change the color
saturation (the
intensity of the colors)
and color tone (the
degrees of lightness
and darkness).
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Click the Crop button
arrow to find the Crop
to Shape command,
which you can use to
force a graphicto a
specific shape.

The Picture
Tools Format

To change the

To precisely align objects
color and width

with other objects or

of a picture’s tab appears with the edges of the
border, use the when a bitmap slide itself, click the
Picture Border image is Align button, and then

button. selected.

choose a command.
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Use Picture
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"We Arrange Travel and Vacation

Packages for:

¢ Cruisers

* Sightseers

* Fishermenand hunters

* Hikers and trekkers

¢ Climbersand
mountaineers

Drag a corner sizing handle
to maintain the object’s
aspect ratio—the ratio of

the object’s height and
width—as you resize it.
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( You can drag sizing handles on 4
| aselected object to resize it.
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Use the Shape To change the color
Fill button to and width of a shape's
change the fill border, use the Shape

Outline button.

color of a shape.

The Drawing Tools
Format tab appears
when a vector graphic or
a text box— including
the slide’s title and
content placeholders—is
selected.

The Shape Height box
contains the height
measurement of the
selected object, and the
Shape Width box contains
the width measurement.
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Use Shape Styles to apply (" Click the Shape Effects button to
a style to a shape. add special effects to a shape.

Our Pillars of Success

You can drag a rotate
handle to rotate an object,
or you can click the Rotate
button to open a menu of

Rotate and Flip commands.

To draw a shape the size
you want, click the

location where you want
a corner of the shape to
appear, and then drag
the mouse until the
outline of the shape is
the desired size.

Alaskan Cruises and Land Tours

You can drag the adjustment
handle to change the
proportions of a drawn
shape without changing
the overall size of the
drawn shape.
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Understanding Graphics

* Graphics are saved in a variety of file types

Figure 2-1 Common image file formats

Format Abbreviation Type
Windows Bitmap BMP Bitmap
Tagged Image File TIF Bitmap
Graphics Interchange Format GIF Bitmap
Portable Network Graphic PNG Bitmap
Joint Photographic Experts Group JPEG Bitmap
Scalable Vector Graphic SVG Vector
Windows Metafile WMF Metafile
Enhanced Metafile EMF Metafile
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Adding a Graphic from a File

* You can insert graphics stored on your
computer on a slide using the Insert Picture
from File button in a content placeholder or

the Picture button in the Images group on the

I n S e rt t a b Figure 2-2 Slide 4 after inserting picture
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Inserting Clip Art

Clip art includes electronic illustrations, photographs, and other
graphics stored in collections so that you can easily locate and
insert them into documents and presentations

Switch to a layout that includes a content placeholder, and then
in the content placeholder, click the Clip Art button; or click the
Insert tab on the Ribbon, and then in the Images group, click
the Clip Art button

In the Clip Art task pane, type a keyword or multiple keywords
in the Search for box

Click the Results should be arrow, and then select the check
boxes next to the types of clip art for which you want to search
Click the Go button

In the task pane, click the clip art that you want to insert into
the slide
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Inserting Clip Art

Figure 2-3 Clip Art task pane open in the presentation window
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Resizing and Repositioning

a Graphic

* The easiest way to change the size of a graphic
is to drag its sizing handles

* You can also change a graphic’s size using the
Shape Height and Width boxes in the Size
group on the Format tab that appears when a
picture or drawing is selected
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Formatting Objects

* The Adjust group on the Picture Tools Format
tab contains buttons you can use to apply
photo editing effects, including the Color

Figure 2-7 Color gallery for a photograph
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Formatting Objects

* You can also change the color and width of an
object’s border, add special effects to an
object, and change the shape of a picture

Figure 2-8 Picture with modified border, shadow, and shape
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Formatting Objects

* An easy way to apply several formats at once
to an object is to apply a style to it. Both of the

contextual Format tabs contain a Styles gallery

Figure 2-9 Clip art with a style and a border applied
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Drawing and Formatting Shapes

* Click the Insert tab on the Ribbon, and then, in
the lllustrations group, click the Shapes button

* Choose the shape you wish to apply
* Click and hold the mouse to draw the shape
* Release the mouse button

* You can add text to a shape by selecting the
shape and typing
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Drawing and Formatting Shapes
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Inserting and Formatting Text
Boxes

* Click the Insert tab on the Ribbon.
* |n the Text group, click the Text Box button

Figure 2-13 Text boxes added around the triangle
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Flipping and Rotating Objects

* To flip an object, you can use one of the Flip
commands on the Rotate menu, which you
open by clicking the Rotate button in the

Arrange group on the Format tab
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Slide Master View
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Modifying the Slide Master

* Click the View tab on the Ribbon, and then, in
the Master Views group, click the Slide Master
button

* Click the Slide Master or the layout master
thumbnail that you want to modify

* Make changes to the master, such as changing
the background color; modifying the text size,
color, font, or alignment; inserting clip art,
graphics; changing the size or location of text
placeholders; and so forth

* |In the Close group, click the Close Master View
button
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Modifying the Slide Master

Figure 2-16 Title and Content Layout master with image
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Modifying Text Placeholders

Figure 2-18 Title and Content Layout master with resized placeholders

Slide Master Home Insert Transitions Animations Review View Format

t p M B cotors - s g
’ ] Titte ‘ I cotors 33 Background Styles - L‘i] E
A Rename (i) S [A] Fonts -
Insert Siide Insert Insert 7] Footers | Themes . | 71 Hide Background Graphics | Page Slide Clase
Master Layout Placeholder * - [Oetteats Setup Orientation~  Master View

Edit Master Master Layout Edit Theme Background . Page Setup Close

= Click to edit Master tiﬂé/

style ]

¢ Click to edit Master text styles
¢ Second level
» Third level

- Fourth level
« Fifth level

left border of
placeholders at
right edge of
the graphic

ad

New Perspectives on Microsoft PowerPoint 2013



Modifying the Font Style

in the Slide Mas

Modified title text placeholder on the Title Slide Layout master
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Creating SmartArt Diagrams

* A diagram visually depicts information or ideas and
shows how they are connected
* SmartArt is a feature that allows you to create
diagrams easily and quickly
— List
— Process
— Cycle
— Hierarchy
— Relationship
— Matrix
— Pyramid
— Picture
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Creating SmartArt Diagrams

Switch to a layout that includes a content
placeholder, and then in the content placeholder,
click the Insert SmartArt Graphic button; or click the
Insert tab on the Ribbon, and then in the lllustrations
group, click the SmartArt button

In the Choose a SmartArt Graphic dialog box, select
the desired SmartArt category in the list on the left

In the center pane, click the SmartArt diagram you
want to use

Click the OK button
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Creating SmartArt Diagrams

Figure 2-25 SmartArt pic

ture diagram with the Title Only layout applied
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Converting a Bulleted List

. c Art Di

* Click anywhere in the bulleted list

* [n Paragraph group on the Home tab, click the
Convert to SmartArt Graphic button, and then
click More SmartArt Graphics

* |n the Choose a SmartArt Graphic dialog box,
select the desired SmartArt category in the list
on the left

* |n the center pane, click the SmartArt diagram
you want to use

* Click the OK button
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Adding a Shape
to a SmartArt Diagram

* Click the shape next to the position where you
want to insert the shape

* Click the SmartArt Tools Design tab on the
Ribbon

* |n the Create Graphic group, click the Add
Shape button arrow, and then click the
appropriate command on the menu

* Type the text in the new shape
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Animating Objects

Figure 2-30 Effect Options menu for the Fly In animation applied to a SmartArt diagram
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Inserting Headers and Footers

.on Handouts and Notes Pages

* |[n PowerPoint, you cannot insert a header on
slides in the presentation, but you can insert a
header in handouts and notes pages

* Click the Insert tab, and then click the Header
& Footer button in the Text group. The Header
and Footer dialog box opens with the Slide tab
on top

* Click the Notes and Handouts tab
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Inserting Headers and Footers

Figure 2-31 Notes and Handouts tab in the Header and Footer dialog box
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Broadcasting a Presentation

* You can broadcast a presentation over the Internet and to
anyone with the URL

* Click the Slide Show tab on the Ribbon, and then in the
Start Slide Show group, click the Broadcast Slide Show
button; or click the File tab on the Ribbon, and then in the
navigation bar click the Save & Send tab; in the Save &
Send section, click Broadcast Slide Show; and then in the
pane on the right, click the Broadcast Slide Show button

* In the Broadcast Slide Show dialog box, click the Start
Broadcast button

* In the dialog box that asks for your Windows Live
credentials, type your Windows Live ID user name and
password, and then click the OK button
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Broadcasting a Presentation

* In the dialog box that displays the unique link for
your presentation, click Copy Link to copy the link to
the Clipboard, paste the copied link in an email

message or oth
and send ittot
broadcast; or ¢

er form of electronic communication
Ne people you are inviting to your
ick Send in Email to start your email

program and p

ace the link in a new message

e Ask audience members to click the link to open the
Web page or to paste the link in the Address bar of
their browser, and then press the Enter key to go to

the Web page
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Broadcasting a Presentation

* |n the Broadcast Slide Show dialog box, click
the Start Slide Show button

* Advance through the slide show, and then end
the slide show

* |n the yellow Broadcast View bar, click the End
Broadcast button; or in the Broadcast group
on the Broadcast tab, click the End Broadcast
button

* |In the confirming dialog box, click the End
Broadcast button
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Broadcasting a Presentation

Figure 2-36 Title slide of your presentation in the Internet Explorer browser during a broadcast
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